United States
Skip navigation links

Updates & Downloads


vivosmart, PSOC software version 2.10

as of December 4, 2014

Use Garmin Express to install this file.

(33 KB)

View system requirements

Notes:


Change History

Changes made from version 2.00 to 2.10:

System requirements

  1. IBM-compatible PC running Windows 2000 or later operating system and an available USB port.